• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 KIA Telluride Forum and KIA Telluride community dedicated to KIA Telluride owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the KIA Telluride Forum today!

FCA malfunctioning

LouieC5

New Member
Messages
3
Likes
0
Location
Buffalo, NY, USA
#1
Today driving into work I got an error on my 2020 Telluride. It said something like the radar isn't working therefor the FCA isn't operating. Now I live in Buffalo, NY. It started snowing pretty heavily today. I am hoping it had to do with the weather as opposed to something actually malfunctioning with the radar system. Has anyone else had this issue? If so did it clear up on it's own or did you have to take it in? Was it snowing when you experienced this issues? Thanks!
 

dhendrix

New Member
Messages
13
Likes
7
Location
Lancaster, SC, USA
#2
Today driving into work I got an error on my 2020 Telluride. It said something like the radar isn't working therefor the FCA isn't operating. Now I live in Buffalo, NY. It started snowing pretty heavily today. I am hoping it had to do with the weather as opposed to something actually malfunctioning with the radar system. Has anyone else had this issue? If so did it clear up on it's own or did you have to take it in? Was it snowing when you experienced this issues? Thanks![
 

dhendrix

New Member
Messages
13
Likes
7
Location
Lancaster, SC, USA
#3
Mine has done that during heavy rain or excessive water on road while raining. Once clear of those it always returns to normal.
 
OP
LouieC5

LouieC5

New Member
Messages
3
Likes
0
Location
Buffalo, NY, USA
Thread Starter #4
Mine has done that during heavy rain or excessive water on road while raining. Once clear of those it always returns to normal.
Yeah I'm hoping that's the case with mine as well. It's never happened to me in the rain, but today was the first heavy snowfall we've had since I bought it back in October.
 
Messages
318
Likes
174
#5
Yeah I'm hoping that's the case with mine as well. It's never happened to me in the rain, but today was the first heavy snowfall we've had since I bought it back in October.
Clean the debris off the radar, the rectangular box just below the front license plate.
 
OP
LouieC5

LouieC5

New Member
Messages
3
Likes
0
Location
Buffalo, NY, USA
Thread Starter #6
Clean the debris off the radar, the rectangular box just below the front license plate.
I did just that and it's working fine. I was hoping it had to do with the snow and I was right. Thx!
 
Messages
3
Likes
0
Location
Ohio
#7
I've had the same problem with my 2021 SX when slush or snow builds up on the radar unit. The problem goes away when the slush is cleaned or melts off.
 
Thread starter Similar threads Forum Replies Date
Scarlett Maintenance, Warranty Issues & Trouble 1

Similar threads



Top