• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 KIA Telluride Forum and KIA Telluride community dedicated to KIA Telluride owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the KIA Telluride Forum today!

Electronics not working.

Moira

New Member
Messages
1
Likes
0
Location
Ft Lauderdale, FL, USA
#1
I ordered my Telluride EX in June 2019 and absolutely love the size and the fuel efficiency but I have had problems with the electronic system since I got it. The lane assist is sporadic, sometimes it helps you, other times you can cross 2 lanes and nothing. The phone would often sound like I was talking under water, I would have to take it off the car's bluetooth and use handheld. I took it to Gunther, the service rep videoed the phone making the sound, nothing was done and then they lost the video. The navigation system (which doesn't come with all models, only EX and up, so you are paying extra for it) is shocking. I was looking for a car wash and it tried to sent me to one in Wisconsin, I live in SoFla. I was at Homegoods, used the nav to find another one, followed the directions to find I had been taken on the highway, zig -zagging around, BACK TO THE SAME HOMEGOODS. When using the nav it would generally take me past the left turn to the next traffic light to do a u-turn and come back. I was going to Walmart and it was across the intersection on the right yet the nav wanted me to turn right go to the next lights, u-turn, come back and then to right to get to the entrance which was directly in front of me. It stopped finding addresses with me saying "find this address". Also it wouldn't find the adress when I entered it either. Kia told me i needed to update the software which took 2 1/2 hours and you can't switch the car off. I don't have a garage so my husband sat in the car the whole time.. The front monitor went off telling me I had hit something, I got told "it happens." Huh? I never got the UVO to work again electronics. I have taken the car in time and time again for over a year now and got told they have to replicate the problem. Well everything is intermittent so that was impossible. I then started videoing all the problems and sent them to Kia. Again they give me a Kia customer service representative and nothing was ever resolved. I eventually managed to get the car in showing Kia the problem with the phone system again. Three weeks later I start calling the manager asking what's happening and get told they had only just sent the video in to Head Office. I get called a week later to say they are going to replace the radio and that will take care of everything thats wrong. I picked up my car on Friday 13th November after the radio has been replaced. Set up my Bluetooth with my phone. Drive away and ask the Nav "find ..(my home address) and low and behold after at lease a minute it can't find it. Ask it to find a local donut place by name and then address, won't do that either. I just got off the phone with the Kia Rep and again I'm getting talk that I need to upgrade the Nav system. I want the car replaced which Kia has refused to do. I feel I am being given the run around by the dealership and Kia and am so upset.
 
Messages
306
Likes
163
#2
I ordered my Telluride EX in June 2019 and absolutely love the size and the fuel efficiency but I have had problems with the electronic system since I got it. The lane assist is sporadic, sometimes it helps you, other times you can cross 2 lanes and nothing. The phone would often sound like I was talking under water, I would have to take it off the car's bluetooth and use handheld. I took it to Gunther, the service rep videoed the phone making the sound, nothing was done and then they lost the video. The navigation system (which doesn't come with all models, only EX and up, so you are paying extra for it) is shocking. I was looking for a car wash and it tried to sent me to one in Wisconsin, I live in SoFla. I was at Homegoods, used the nav to find another one, followed the directions to find I had been taken on the highway, zig -zagging around, BACK TO THE SAME HOMEGOODS. When using the nav it would generally take me past the left turn to the next traffic light to do a u-turn and come back. I was going to Walmart and it was across the intersection on the right yet the nav wanted me to turn right go to the next lights, u-turn, come back and then to right to get to the entrance which was directly in front of me. It stopped finding addresses with me saying "find this address". Also it wouldn't find the adress when I entered it either. Kia told me i needed to update the software which took 2 1/2 hours and you can't switch the car off. I don't have a garage so my husband sat in the car the whole time.. The front monitor went off telling me I had hit something, I got told "it happens." Huh? I never got the UVO to work again electronics. I have taken the car in time and time again for over a year now and got told they have to replicate the problem. Well everything is intermittent so that was impossible. I then started videoing all the problems and sent them to Kia. Again they give me a Kia customer service representative and nothing was ever resolved. I eventually managed to get the car in showing Kia the problem with the phone system again. Three weeks later I start calling the manager asking what's happening and get told they had only just sent the video in to Head Office. I get called a week later to say they are going to replace the radio and that will take care of everything thats wrong. I picked up my car on Friday 13th November after the radio has been replaced. Set up my Bluetooth with my phone. Drive away and ask the Nav "find ..(my home address) and low and behold after at lease a minute it can't find it. Ask it to find a local donut place by name and then address, won't do that either. I just got off the phone with the Kia Rep and again I'm getting talk that I need to upgrade the Nav system. I want the car replaced which Kia has refused to do. I feel I am being given the run around by the dealership and Kia and am so upset.

Wow a lot of things here but I think it's operating normally.

I doubt LKA will always work all since it depends on the condition of the lane marking and what the camera can see.

Navigation generally sucks without UVO service. I assumed you didn't get UVO after the free trial expired? If so, unfortunately the voice search is very, very limited and nearly useless. Even if you type in the address it says that it cannot find the address since it appear to use an online database first. Once you get the error you have to press the soft button that says "search with built-in map". That message is hard to see. It's in the middle/top of the screen. After you click on it, it'll find the correct location using the built it map. I couldn't find a way to default it to using the built-in map. I suggest you use Apple Carplay or Android Auto for voice navigation.

Sounds like the Bluetooth problem is resolved with the new radio.
 


Top