• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 KIA Telluride Forum and KIA Telluride community dedicated to KIA Telluride owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the KIA Telluride Forum today!


Proximity Door Unlock Not Working

Messages
5
Likes
0
Location
Georgia
#1
Just purchased a 2023 SX. Driver side door doesn’t unlock anymore when I grab the handle.

Worked for a few days. Passenger side works correctly and with the Digital Key.

Anyone else have this happen? Bad part?
 

snafu777

New Member
Messages
1
Likes
0
Location
mantua, NJ
#2
I have the exact same thing happening with my 2023 SX. Passenger side works when in proximity but driver side does not or when I use sensor on the handle. Worked up until today. Have had the car for 45 days.
 
OP
C
Messages
5
Likes
0
Location
Georgia
Thread Starter #3
I have the exact same thing happening with my 2023 SX. Passenger side works when in proximity but driver side does not or when I use sensor on the handle. Worked up until today. Have had the car for 45 days.
Dealership says they are going to have to take the door apart to fix it. 3 hour job. Will have an update for you next Wednesday.
 
OP
C
Messages
5
Likes
0
Location
Georgia
Thread Starter #4
After a 3 hour wait at the dealership, they now believe it is an electrical issue then need to track down and not a door handle issue.

They now need to hold it an additional 2 days.
 
OP
C
Messages
5
Likes
0
Location
Georgia
Thread Starter #5
Not an Electrical issue. Loose pin.

Shop report: “Found that poor tension at connector D06 at the door handle was poor causing poor contact and bad signals to the IBAU.”

“Pin tension corrected and tested with no faults.
 

Judeland

New Member
Messages
2
Likes
0
Location
Lafayette, La.
#6
Just purchased a 2023 SX. Driver side door doesn’t unlock anymore when I grab the handle.

Worked for a few days. Passenger side works correctly and with the Digital Key.

Anyone else have this happen? Bad part?
I just bought a brand new Telluride SXP 3 days ago (2/23/3023) and the problem started as soon as I got home with it. Very frustrating!!
 
OP
C
Messages
5
Likes
0
Location
Georgia
Thread Starter #8
Hopefully just the Pin Connector. Mine has worked correctly since.
 

mssommers1

New Member
Messages
1
Likes
0
Location
Charlotte, NC
#12
Have same issue. Dealer disconnected battery and it started working at dealership. Was not working again when we got home. They said last problem they found required engineers from Korea to come over to the US for 2 weeks and didn't find it. Sounds like BS.
For those that had pin connection fixed, is it still working months later?
 

nbrecht

New Member
Messages
3
Likes
0
Location
orange county
#13
Same thing when my battery went dead and had to recharge it suddenly started working again. My battery went dead because I left the sun visor mirror open for 3 days and it drained my battery. Whole separate issue. But it did fix my proximity sensor issue.
 
Messages
1
Likes
0
Location
Littleton Colorado
#14
I was experiencing the exact same problem as you all mentioned above! Think I stumbled upon the culprit! If you have an employee key card fob or parking/apartment fob that you carry on you daily try removing it and testing the car key again. My car was picking up the signal from my work fob in my wallet and missing the KIA key signal. All of a sudden it start working again after I was laid off and turned my work fob back in. Always assumed it was the car messing up but really it was just the dead end job killing my soul and my signal.
 

Similar threads



Top