• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 KIA Telluride Forum and KIA Telluride community dedicated to KIA Telluride owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the KIA Telluride Forum today!


I'm happy with my Telly but....

ilicmps

New Member
Messages
3
Likes
0
Location
San Diego, CA, USA
#1
Hello I'm new here but I've had my Telluride ex since April I love and I get a lot of compliments on it. Recently while driving in the fwy a rock hit my windshield on the top corner on the passenger side. The next morning the small crack had spread all across the windshield, I had to had it replaced and now all the sensors like the smart cruise control, lane departure, lane assist doesn't work like it used to before they replaced the windshield. I took it back to the dealership for them to have it calibrated again but it shows that everything is working fine. Before it happened as soon as I would get close to it car it would slow down and warned me there was a cat approaching and now it doesn't. I'm so frustrated cause now it seen like everything is just super delay. Has anyone experienced any of this like me? Please help
 
Messages
320
Likes
177
#2
Before it happened as soon as I would get close to it car it would slow down and warned me there was a cat approaching and now it doesn't. I'm so frustrated cause now it seen like everything is just super delay. Has anyone experienced any of this like me? Please help
Mine never “slowed down” unless I was using SCC. Are you saying your KT used to slow down, without the SCC engaged or are you saying SCC is slow to respond.

If latter, there are setting you can change, if former then I don’t think that’s how forward collision avoidance will respond.

Also, it has pedestrian detection, I don’t know about cat detection is suppose to work.
 
Messages
88
Likes
50
#3
Hello I'm new here but I've had my Telluride ex since April I love and I get a lot of compliments on it. Recently while driving in the fwy a rock hit my windshield on the top corner on the passenger side. The next morning the small crack had spread all across the windshield, I had to had it replaced and now all the sensors like the smart cruise control, lane departure, lane assist doesn't work like it used to before they replaced the windshield. I took it back to the dealership for them to have it calibrated again but it shows that everything is working fine. Before it happened as soon as I would get close to it car it would slow down and warned me there was a cat approaching and now it doesn't. I'm so frustrated cause now it seen like everything is just super delay. Has anyone experienced any of this like me? Please help
Windshield has nothing to do with those sensors....
 
Messages
80
Likes
29
#4
The sensors for the smart cruise control is in the lower front grill. There are no sensors attached to the windshield. You can adjust the distance from the steering wheel button.

sensor.png
steering.png
 
Messages
80
Likes
29
#5
In case you need it from page 5-73 in the Owner's Manual.
  • Press the MODE button several times on the steering wheel until 'User Settings' menu appears on the LCD.
  • Fast: Vehicle speed to the vehicle ahead to maintain the set distance is faster than normal speed.
  • Normal: Vehicle speed to the vehicle ahead to maintain the set distance is normal.
  • Slow: Vehicle speed to the vehicle ahead to maintain the set distance is slower than normal speed.
smart-cruise-control.png
 
Messages
76
Likes
17
#6
Welcome to the forum! Like the above poster stated you can change the sensitivity in the settings
 
Messages
33
Likes
13
Location
Minneapolis, MN, USA
#7
Battery may have been disconnected during the service, or a software update, which reset your settings.


Sent from my iPhone using Tapatalk
 

KiaFan

Member
Staff Member
Messages
300
Likes
100
#8
Battery may have been disconnected during the service, or a software update, which reset your settings.


Sent from my iPhone using Tapatalk
this is probably what happened.
 
OP
I

ilicmps

New Member
Messages
3
Likes
0
Location
San Diego, CA, USA
Thread Starter #9
Mine never “slowed down” unless I was using SCC. Are you saying your KT used to slow down, without the SCC engaged or are you saying SCC is slow to respond.

If latter, there are setting you can change, if former then I don’t think that’s how forward collision avoidance will respond.

Also, it has pedestrian detection, I don’t know about cat detection is suppose to work.
The SCC is slow to respond. And sorry I meant to say car not CAT. Lol. I was pulling out of target parking and a car was coming behind me and I couldn't see cause there was a big car that was blocking my view and my telly sensor didn't detect the oncoming car behind me. Good thing I was pulling out really slow and saw the car coming on my camera. thank you for your response
 
OP
I

ilicmps

New Member
Messages
3
Likes
0
Location
San Diego, CA, USA
Thread Starter #10
In case you need it from page 5-73 in the Owner's Manual.
  • Press the MODE button several times on the steering wheel until 'User Settings' menu appears on the LCD.
  • Fast: Vehicle speed to the vehicle ahead to maintain the set distance is faster than normal speed.
  • Normal: Vehicle speed to the vehicle ahead to maintain the set distance is normal.
  • Slow: Vehicle speed to the vehicle ahead to maintain the set distance is slower than normal speed.
View attachment 1991
I have and it doesn't detect a car on my blind spot either just like the smart cruise control doesn't slow down to the speed of the car in front of me. And the lane assist used to beep as soon as I would get too close to any lane even if I would keep it in my lane
 

ucinn

Member
Staff Member
Messages
296
Likes
143
#11
Make sure you don't have these turned off with the switch which will keep them from working. I believe the switches for both would be near your left knee when sitting in the driver's seat. (for the blind spot and LKA)
 

Similar threads



Top